OpenStack packaging progress

Mark McLoughlin markmc at redhat.com
Mon Aug 29 16:12:48 UTC 2011


Hi Angus,

On Mon, 2011-08-29 at 21:38 +1000, Angus Salkeld wrote:
> Hi Mark
> 
> 
> > What you can do to help:
> > Volunteer to co-maintain the packages
> 
> I can help with one or two of these.

Awesome, thanks!

> > Try out the "getting started" instructions and point out any problems
> 
> I ran through this and the only question I have is about setting up the
> network.
> 
> I changed:
> sudo nova-manage network create markmc 10.0.0.0/24 1 256 --bridge=br0
> to
> sudo nova-manage network create asalkeld 192.168.200.0/24 1 256 --bridge=br0
> (as my eth0 is on a 10.0.0. network)
> 
> When I ran the instance it did show up in virt-manager but seemed stuck
> in the bootup:
> "gPXE bla bla ..."
> "Booting from ROM..."
> 
> and it gets stuck there.

Does the log here:

  /var/lib/nova/instances/instance-*/console.log

show anything else?

I see the same here. The instance has booted fine, but all output is
going to the serial console which ends up in console.log

Can you connect with ssh? That images that I list in the howto don't
seem to automatically add your public SSH key at boot, so I manually
changed the root password on it by loopback mounting it and doing chroot
passwd

> Is this trying to boot from an image off of the internet?
> I suspect my network is the issue, but not sure what.
> iptables & selinux is off and I can ping the VM.
> 
> Any ideas?

> > Help out with the TODO list
> 
> I'll have a look at the init scripts and try convert them to systemd
> service files.

Coolness! Starting with glance?

Cheers,
Mark.




More information about the cloud mailing list