ANNOUNCE: oz 0.8.0 release

Chris Lalancette clalancette at
Sat Jan 14 13:59:25 UTC 2012

Hey Pádraig,

2012/1/13 Pádraig Brady <P at>:
> On 01/11/2012 04:14 PM, Chris Lalancette wrote:
>>      A tarball of this release is available, as well as packages for
>> Fedora-16.  Instructions on how to get and use Oz are available at
> The links to 0.8.0 haven't been added at the above URL.

Ug, yes.  I'll send an updated patch to the website.

> I found Fedora _15_ rpms on fedorapeople which installed fine on F16.

Yeah, sorry, that was a typo on my part; I only built F-15 packages this time.

> There seems to be some issue with error timeouts on this version.
> I first tried to create an image without enough free space:
> oz-install -t 50000 -u -d3 -x blah.xml /var/lib/pacemaker-cloud/jeos/F16-x86_64-jeos.tdl
> This hung at "cleaning up" phase _forever_. strace says hung at:
>    sendto(14, "var/lib/oz/isocontent/F16-x86_64"..., 1585278, 0, NULL, 0^C <unfinished ...>
> Ctrl-c unlocked after which got:
>    94.60% done, estimate finish Fri Jan 13 18:52:46 2012
>    genisoimage: No space left on device. cannot fwrite 32768*1
> So after freeing up enough space I tried again and got farther.
> However this also hung forever at the "Unmounting all" stage.
> This only happens if "customizing image", and only with SELinux on.
> strace says: recvfrom(14,...
> Anyway apart from the SELinux issue, I got out of the infinite wait with
> Ctrl-C and it then proceeded to timeout as expected.

Hm, probable SELinux problem.  I hadn't seen that, but I'll try it out
and see what happens.

Thanks for trying,

More information about the cloud mailing list