Running horizon/dashboard from git with openstack from rawhide

Derek Higgins derekh at
Tue Jan 17 09:44:33 UTC 2012

Hi ikke,
   I haven't tried it out yet but according to this mail, it looks like
a temporary problem,

I haven't tried the solution but it looks like it should solve our
problem, I can wait for a fix to be committed but if you try out the
workaround and aren't successful I can give it a go and see if I have
any luck.


On 01/17/2012 08:34 AM, Tengvall, Ilkka (NSN - FI Espoo) wrote:
> Hi guys,
> I would need some help with dashboard setup to get past the issue:
> "*Error: *Unable to get service info: This error may be caused by a
> misconfigured Nova url in keystone's service catalog, or by missing
> openstackx extensions in Nova. See the Horizon README."
> I'm new to openstack, and started to evaluate it on fedora. I installed
> openstack from rawhide, and configured it and verified I can run guests
> in there. Then I went ahead to install dashboard. It required keystone,
> which I installed and created the admin user with token, and verified it
> can login using curl. Then I took the horizon/dashboard from git. After
> banging my head to wall for few times now I thought to ask you guys,
> since you face the same problem, even though you use the latest git
> openstack, it seems:
> I don't see the log line as described there:
> "2012-01-16 11:48:05,325 AUDIT nova.api.openstack.extensions [-] Loaded
> extension: ADMIN"
> where as I see something related failing (api.log):
> "
> 2012-01-17 08:58:29,289 AUDIT extensions [-] Loading extension file:
> 2012-01-17 08:58:29,289 WARNING extensions [-] Did not find expected
> name "Admin_only" in /usr/lib/python2.7/site-packages/nova/api/open
> stack/contrib/
> "
> No sign of openstackx in that log, which might be the origin of the
> problem. I have this on my noca.conf (copied the last two lines from the
> above mail thread):
> ------------------------
> --osapi_extensions_path=/root/src/horizon/.horizon-venv/src/openstackx/extensions
> --osapi_extension=nova.api.openstack.v2.contrib.standard_extensions
> --osapi_compute_extension=extensions.admin.Admin
> ------------------------
> It didn't work any different before adding the last to lines either. I
> also tried the patch to mentioned in the mailthread, but it
> doesn't make a difference.
> Any help would be appreciated. I also wonder about Alan Pevec's comment
> about using python nova client, is it already set up into dashboard
> somehow, is there implementation of dashboard already available for it?
> As the git of horizon seems to still use openstackx...
> Here another mail thread started by me, which pointed me to this list:
> There is more
> command history to what I did on my machine, if it helps.
> BTW, I joined the #fedora-cloud at freenode if you hang around there, my
> nick is ikke-t, if you would be willing to help there.
> BR,
>  -it

More information about the cloud mailing list