Broken dependencies: cloud-utils

Juerg Haefliger juergh at gmail.com
Mon Mar 18 08:59:29 UTC 2013


On Mon, Mar 18, 2013 at 9:40 AM, Sandro "red" Mathys
<red at fedoraproject.org> wrote:
> On Mon, Mar 18, 2013 at 9:21 AM, Juerg Haefliger <juergh at gmail.com> wrote:
>>
>> > cloud-utils has broken dependencies in the epel-6 tree:
>> > On i386:
>> >         cloud-utils-0.27-0.2.bzr216.el6.noarch requires qemu-img
>> > On ppc64:
>> >         cloud-utils-0.27-0.2.bzr216.el6.noarch requires qemu-img
>> > Please resolve this as soon as possible.
>>
>> Is this something that I need to fix or can I ignore it?
>
>
> You should fix this. But unless cloud-utils can somehow work without
> qemu-img, the solution will simply be to stop building for i386 and ppc64.
> RHEL only provides qemu-img for x86_64 and attempts to bring it to the other
> architectures through EPEL were met with issues (see
> https://bugzilla.redhat.com/show_bug.cgi?id=877259).
>
> The line you need for EL6 builds would be:
> ExclusiveArch: x86_64

That make sense, thanks. Now how would I go about this process-wise?
I'd like to keep the same spec file for both Fedora and EPEL and could
do some %{?rhel} magic but then I need to update all branches master,
f18 and el6 and push a new f18 package? Or does it make more sense to
update the el6 branch only?

Thanks
...Juerg


> -- Sandro
>
>
>
> _______________________________________________
> cloud mailing list
> cloud at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/cloud
>


More information about the cloud mailing list