Heads-up: GIMP 2.7/2.8 in Rawhide, license change to (L)GPLv3+

Nils Philippsen nils at redhat.com
Thu Dec 15 19:48:55 UTC 2011


I just finished with the Fedora 17 feature page for GIMP 2.8[1] and
built gimp-2.7.4 into Rawhide.

GIMP changed its licensing to GPLv3+ (app, included plugins) and LGPLv3+
(libraries) from the 2.7 development versions on. I've checked dependent
packages and found that all are listed with compatible licenses in their
spec files (CeCill v2, GPLv2+, GPLv3+, Public Domain). One minor
licensing issues was introduced with this change, namely with poppler,
used for importing PDFs and GPLv2 only. For the moment, GIMP packages
from 2.7.x on won't use poppler, but the PostScript plugin for importing
PDFs. This is a workaround until the next stable version poppler 0.20
which will be based off xpdf-3.03 (or later), thusly GPLv2/GPLv3
dual-licensed and compatible again.

While APIs used by external plugins should be backwards-compatible, I'll
rebuild packages using GIMP libraries (i.e. having GIMP plugins) against
the current (not yet stable) version 2.7.4 and against the stable
version when it's there, just to be on the safe side. These are the
affected (source) packages:

GREYCstoration: deebs
gimp-fourier-plugin: fabiand
gimp-lqr-plugin: slankes
gimp-resynthesizer: ewan
gimpfx-foundry: rvinyard
gutenprint: twaugh - jpopelka
mathmap: rnorwood
ufraw: nphilipp
xsane: nphilipp

I plan to do the first round of rebuilds tomorrow, so if there's any
reason why I shouldn't rebuild one of these, or you want to rebuild a
package by yourself, speak up ;-).


[1]: https://fedoraproject.org/wiki/Features/GIMP_2.8
Nils Philippsen      "Those who would give up Essential Liberty to purchase 
Red Hat               a little Temporary Safety, deserve neither Liberty
nils at redhat.com       nor Safety."  --  Benjamin Franklin, 1759
PGP fingerprint:      C4A8 9474 5C4C ADE3 2B8F  656D 47D8 9B65 6951 3011

More information about the devel-announce mailing list