[HEADS UP] Update to Django-1.6, even for f20

Matthias Runge mrunge at matthias-runge.de
Wed Mar 26 11:44:21 UTC 2014


On Tue, Mar 18, 2014 at 08:17:36AM -0400, Stephen Gallagher wrote:
> When this goes to updates-testing for F20, please make a
> devel-announce post describing what changes that Django package owners
> should make in order to keep their package on Django 1.5 or older if
> they need to.

Earlier today, I've built Django-1.6 for Rawhide and for F20 as well and 
submitted the upgrade to f20-testing via bodhi[1]. Please test
and leave karma there.

If you're a packager and your package requires an older Django version,
please change your package to require python-django15 and add 

from pkg_resources import require
require('Django>=1.5,<1.6')

to appropriate location(s) in your package. There is a blog post[2] on
how to consume older versions of Django. Even if the update to
Django-1.6 won't make it to stable, it should be safe to change your 
package anyways, as older Django versions will be retired sooner or
later.

If you require help, please contact me off list.

Thanks,
Matthias

[1] https://admin.fedoraproject.org/updates/python-django-1.6.2-1.fc20
[2] https://www.matthias-runge.de/2014/03/26/fedora-django-1-6/
-- 
Matthias Runge <mrunge at matthias-runge.de>


More information about the devel-announce mailing list