vte for FC3/FC4 testing

Warren Togami wtogami at redhat.com
Tue Mar 8 20:20:51 UTC 2005

Kjartan Maraas wrote:
> I tried adjusting VTE_DISPLAY_TIMEOUT and VTE_COALESCE_TIMEOUT to find
> the best compromise between speed and smooth output in the terminal and
> I *think* I found something that should be ok. If others want to
> experiment with those values to see if it can be improved further that
> would be nice. The other speedups are partly from the patches already in
> FC3 and also some new performance patches from Benjamin Otte.

Thanks for your efforts!

>>* Mon Mar 07 2005 Warren Togami <wtogami at redhat.com> 0.11.12-1
>>- upgrade to 0.11.12
>>- remove upstreamed patches (0-2, 5-9)
>>- disable patch3, either not needed anymore, or needs rewriting
>>- reverse patch4, because upstream merged its horrible brokenness
>>- test Novell's excessive malloc for new terminals patch v3
>>   (GNOME #160993)
> Great that this went in so it can get more testing before inclusion
> upstream. I think Novell are shipping with this patch in SuSE 9.3 also.

I just pushed this package to FC4.  Not sure if it will make FC4test1, 
but we'll see.  I didn't get a chance to try your 0.11.13 yet.  Maybe we 
can consider it for rawhide sometime after test1.

>>2) It seems that upstream made a new vte-0.11.12 release with most of 
>>Fedora's patches + more stuff.  This is good.
>>Unfortunately they also merged Patch4: 
>>vte-0.11.11-fix-update-order.patch which was commented out since late 
>>October since it totally screwed up rendering [1].  This is bad.  Makes 
>>me wonder if they actually TESTED 0.11.12 before releasing it upstream...
> Of course it was tested. Nobody reported any problems with rendering
> with the patch included and I can't reproduce the problems you're
> describing myself either. I tried building stuff cat'ing large amounts
> of text ls + ENTER etc.

Uncommented the Patch4 reverse and this is what happens.  Entire lines 
fail to render and instead you get that black box, which appears to be 
the cursor.  If you click on the terminal or ALT-TAB twice, then the en

>>[1] Run gnome-terminal, type ls, hit ENTER a few times.  What should be 
>>the bash prompt turned into a black bar.  You'll see lots of similar 
>>rendering trouble while building something too... like vte.
> As I said, I can't reproduce any of this here. Do you have pointers to
> reports of these problems in bugzilla or anywhere else?

Sorry I should have been less accusatory in my language, especially 
since... this is actually Red Hat's fault.  IIRC back in October Ray 
Strode merged that patch on the request of Owen.  I complained loudly 
because of the bad behavior in those screenshots above.  So Ray 
commented out the patch, but kept it in the SRPM for later review which 
never happened.

Then on February 16 you asked him for details about the Fedora vte 
patches, and he included that disabled patch in his reply.  He wrote, 
"fix-update-order - an owen patch to make sure the screen is fully
redrawn before scrolling.  I think owen said this patch had issues, but
people wanted it anyway I think, so i applied it."

I am puzzled why others are unable to reproduce that behavior.  It 
happens so readily on my FC3 desktop.

Warren Togami
wtogami at redhat.com

More information about the devel mailing list