fc5: modprobe eth2 don't work

Dario Lesca d.lesca at solinos.it
Mon Jul 24 13:56:09 UTC 2006


Hi, on a up to date FC5 host, with 3 network card, if I load the eth2
first of eth1 or eth0 the network interface eth2 is not created:

> [root at cambiami ~]# service network stop
> Arresto dell'interfaccia di loopback:                      [  OK  ]
> [root at cambiami ~]# grep eth /etc/modprobe.conf
> alias eth0 r8169
> alias eth1 natsemi
> alias eth2 natsemi
> [root at cambiami ~]# rmmod r8169 natsemi
> [root at cambiami ~]# rmmod r8169 natsemi
> ERROR: Module r8169 does not exist in /proc/modules
> ERROR: Module natsemi does not exist in /proc/modules
> [root at cambiami ~]# ip a
> 1: lo: <LOOPBACK> mtu 16436 qdisc noqueue
>     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> 5: sit0: <NOARP> mtu 1480 qdisc noop
>     link/sit 0.0.0.0 brd 0.0.0.0
> [root at cambiami ~]# modprobe -v eth2
> insmod /lib/modules/2.6.17-1.2157_FC5/kernel/drivers/net/natsemi.ko
> [root at cambiami ~]# lsmod |grep -E '(r8169|natsemi)'
> natsemi                28193  0
> [root at cambiami ~]# ip a
> 1: lo: <LOOPBACK> mtu 16436 qdisc noqueue
>     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> 5: sit0: <NOARP> mtu 1480 qdisc noop
>     link/sit 0.0.0.0 brd 0.0.0.0
> 18: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
>     link/ether 00:09:5b:1c:9d:97 brd ff:ff:ff:ff:ff:ff
> 19: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
>     link/ether 00:40:f4:5f:8e:d1 brd ff:ff:ff:ff:ff:ff
> [root at cambiami ~]#

In this example, the only network card connect to the network
is the eth0 (r8169), eth1 and eth2 there are not connect
to the network.

How to I can resolve this issue?

I must load the interface in the order that I want.
With previous FC version this was possible.

Many thanks for your suggestions!

-- 
Dario Lesca <d.lesca at solinos.it>




More information about the devel mailing list