java-1.4.2-gcj-compat package problem

Andrew Haley aph at redhat.com
Mon Mar 20 22:00:51 UTC 2006


Dimi Paun writes:
 > From: "Andrew Haley" <aph at redhat.com>
 > >  > [root at dimi ~]# rpm -q jpackage-utils
 > >  > jpackage-utils-1.6.6-1jpp
 > >
 > > You have a bad version of jpackage-utils; remove it and get one from
 > > `yum install'.  You need version 1jpp_2rh.
 > 
 > Heh, 1jpp_2rh > 1jpp, yum should update it, no?

No.

 > But it can't find it anywhere:
 > 
 > [root at dimi ~]# yum update jpackage-utils-1.6.6-1jpp_2rh
 > Setting up Update Process
 > Setting up repositories
 > dries                     100% |=========================|  951 B    00:00
 > dag                       100% |=========================| 1.1 kB    00:00
 > jpackage16-fc             100% |=========================|  951 B    00:00
 > freshrpms                 100% |=========================|  951 B    00:00
 > katz                      100% |=========================|  951 B    00:00
 > macromedia                100% |=========================|  951 B    00:00
 > jpackage16-generic        100% |=========================|  951 B    00:00
 > extras                    100% |=========================| 1.1 kB    00:00
 > updates-released          100% |=========================|  951 B    00:00
 > lattica-development       100% |=========================|  951 B    00:00
 > base                      100% |=========================| 1.1 kB    00:00
 > Reading repository metadata in from local files
 > primary.xml.gz            100% |=========================| 1.1 kB    00:00
 > Could not find update match for jpackage-utils-1.6.6-1jpp_2rh
 > No Packages marked for Update/Obsoletion
 > 
 > Am I missing something?

Yes.  Remove it with `rpm -e'.  Install it with `yum install'.

Andrew.




More information about the devel mailing list