SGML support refactored in F-10?

Matthias Clasen mclasen at
Thu Aug 28 23:48:49 UTC 2008

On Thu, 2008-08-28 at 19:32 -0400, Tom Lane wrote:
> My package libdbi is apparently failing to build in CVS HEAD:
> where the failure looks like
> Converting programmers-guide.sgml to HTML...
> mkdir -p programmers-guide && cd programmers-guide && openjade -t sgml -d ../../doc/include/doc-html.dsl ../../doc/programmers-guide.sgml
> openjade:/usr/share/sgml/docbook/sgml-dtd-4.1-1.0-38.fc10/dbcent.mod:54:0:E: cannot find "iso-amsa.gml"; tried "/usr/share/sgml/docbook/sgml-dtd-4.5-1.0-38.fc10/iso-amsa.gml", "/usr/share/sgml/iso-amsa.gml", "/usr/share/xml/iso-amsa.gml"
> openjade:/usr/share/sgml/docbook/sgml-dtd-4.1-1.0-38.fc10/dbcent.mod:61:0:E: cannot find "iso-amsb.gml"; tried "/usr/share/sgml/docbook/sgml-dtd-4.5-1.0-38.fc10/iso-amsb.gml", "/usr/share/sgml/iso-amsb.gml", "/usr/share/xml/iso-amsb.gml"
> ...
> openjade:../../doc/example-program.sgml:61:21:W: cannot generate system identifier for general entity "gt"
> openjade:../../doc/example-program.sgml:61:21:E: general entity "gt" not defined and no default entity
> openjade:../../doc/example-program.sgml:61:23:E: reference to entity "gt" for which no system identifier could be generated
> openjade:../../doc/example-program.sgml:61:20: entity was defined here
> openjade:../../doc/example-program.sgml:61:45:E: reference to entity "gt" for which no system identifier could be generated
> It doesn't know > ???
> The identical SRPM builds just fine in F-9.  I speculate that somebody's
> refactored the relevant RPMs in F-10, and that I need a new
> BuildRequires to make it work in F-10.  I'm not quite sure where to go
> looking though.  Any clues?

There are problems with the %post of docbook-dtds, which messes up the
xml (and probably sgml) catalogs. I've complained to ovasik about that a
while ago, not sure if it has been fixed. The last time this happened to
me, I manually reran the docbook-dtds %post to get my catalogs back.


More information about the devel mailing list