Libsoup troubles in rawhide (compat-libsoup22 needed)

Dmitry Butskoy buc at odusz.so-cdu.ru
Tue Jan 29 17:41:51 UTC 2008


The new "libsoup" library in rawhide, version 2.3.0, introduces a lot of 
API incompatibility, comparing with the previous 2.2.x versions. There 
are even some design changes, hence it seems impossible for package 
maintainers to do "just a monkey job" of renaming functions etc. In my 
case of "libtranslate" (which depends on libsoup), it requires a deep 
upstream intervention (which, surely, was not in upstream's todo list...)

It could be fine to have "libsoup22" or "compat-libsoup-2.2" package in 
rawhide.


Regards,
Dmitry Butskoy
http:://www.fedoraproject.org/wiki/DmitryButskoy





More information about the devel mailing list