with F9, will we still need ALL X drivers?

sean darcy seandarcy2 at gmail.com
Sun Mar 2 16:42:58 UTC 2008


Ignacio Vazquez-Abrams wrote:
> On Thu, 2008-02-28 at 21:01 -0500, sean darcy wrote:
>> rpm -e xorg-x11-drv-voodoo-1.1.1-1.fc8
>> error: Failed dependencies:
>>          xorg-x11-drv-voodoo is needed by (installed) 
>> xorg-x11-drivers-7.2-9.fc8.i386
> 
> xorg-x11-drivers has been a metapackage with nothing dependent on it for
> a very, very long time. Feel free to erase it.
> 
> 

rpm -e xorg-x11-drv-voodoo
error: Failed dependencies:
         xorg-x11-drv-voodoo is needed by (installed) 
xorg-x11-drivers-7.3-2.fc9.i386

which means that if I did erase it with -nodeps, yum would just drag it 
back in with any update.

Perhaps the answer is the xorg-x11-drivers should not depend on the 
individual drivers, but only have the individual drivers depend on 
xor-x11-drivers.

sean




More information about the devel mailing list