Packages requiring numpy may require a rebuild in f13 and rawhide
spurath at students.uni-mainz.de
Fri Apr 2 06:44:21 UTC 2010
Am Donnerstag, den 01.04.2010, 11:41 -0800 schrieb Jeff Spaleta:
> Found this today with python-basemap. Numpy 1.4.0 introduced some ABI
> changes. Anything that compiles against numpy and hasn't been rebuilt
> since Numpy 1.40 was introduced in late January may need to be rebuilt
> in F-13 and rawhide.
> Just a friendly heads up.
> I'm fixing python-basemap now and then I'm going to start working
> through the rest of the potentially affected packages and firing up
> rawhide rebuilds for those with build times older than the numpy 1.4.0
> introduction. Once that is complete I'll be looking at pushing F13
> updates. Apologizes to anyone's toes. I'm hoping some of the
> affected maintainers see this and take care of this before me. Because
> this is an ABI break, this will show up in weird unexpected runtime
> breakages for users..some easy to hit...some not. Its best to just do
> rebuilds now to avoid trying to to track this down in a series of head
> scratching crash reports.
> Here are the packages that might be affected according to repoquery
> run on my 32bit box with build timestamps prior to numpy 1.4.0.
I don't understand, why you need to rebuild the noarch packages.
Sure, the compiled *.pyc files might be obsolete, but python should
update them automatically. (Means it would be better to rebuild them,
but they are very, very unlikely to break, if they are not.)
Are you sure, packages like gnuplot-py *have* to get rebuild?
Your first programm that causes troubles 'python-basemap' is not noarch.
A compiled programm needs a rebuild, but a programm with just python
files in it?
More information about the devel