Moving lspci and setpci from /sbin to /usr/sbin?

David Eisner deisner at
Tue Feb 2 03:20:34 UTC 2010

On Mon, Feb 1, 2010 at 8:33 PM, Ralf Corsepius <rc040203 at> wrote:
> The "emergency scenario" (/usr not being available) does not work with
> Fedora and probably all RH-based distros, because there are packages in
> /bin/* /sbin/*, which are dynamically linked against libraries in /usr/lib*.

When you said "using a separate /usr partition has never worked", some
(reasonably?) thought you meant it's not even possible to have /usr on
a separate partition.  What you did mean, apparently, was that those
binaries (and only those binaries) in /bin and /sbin which dynamically
link to libs in /usr/lib won't work.

But I don't understand why, in response to Michal's observation
"libpci is in /usr for a long time and there was not any complain so
far", you responded "[y]ou've never seen such a complaint because
using a separate /usr partition has never worked on RH-based distros."

The reason I don't understand is that as long as you have a shell that
doesn't link to libs in /usr, you'll have a working command line.
When you try to figure out why /usr didn't mount, you might try to use
lspci, find libpci is unavailable, and then say "dang."

The fact that nobody has complained may mean it's not a show stopper
(e.g. use dmesg), but it's not a "hen-and-egg" problem, in my opinion.


David Eisner

More information about the devel mailing list