LD Changes To Implicit DSO Linking Update

Braden McDaniel braden at endoframe.com
Fri Feb 19 07:08:47 UTC 2010


On Tue, 2010-02-16 at 17:03 +0100, Enrico Scholz wrote: 
> Gerd Hoffmann <kraxel at redhat.com> writes:
> 
> > Well.  Even pretty fundamental GNOME stuff like gtk2-devel is still 
> > broken.  Look here:
> >
> > [root at localhost ~]# pkg-config --libs gtk+-2.0
> > -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 
> > -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype 
> > -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
> 
> Are all these libraries really required?  Putting them into a linker line
> causes a huge overlinking adding lots of unneeded direct dependencies to
> rpm packages.

gtk+-2.0.pc has:

        Requires: gdk-${target}-2.0 atk cairo gio-2.0 pangoft2

It seems likely that some, if not all, of the latter four belong in
Requires.private.

-- 
Braden McDaniel <braden at endoframe.com>



More information about the devel mailing list