Read this if your package BuildRequires qt(4)-devel!!!
tgl at redhat.com
Tue Feb 23 20:15:00 UTC 2010
Kevin Kofler <kevin.kofler at chello.at> writes:
> I wrote:
>> for all maintainers of packages which BuildRequire qt4-devel (or qt-devel,
>> but the versioned virtual Provides is preferred): please, when you plan to
>> push updates for your packages, ALWAYS CHECK what version of Qt your
>> package got built against and DO NOT PUSH your update to stable before
>> that version of Qt goes stable! A package built against Qt 4.6 WILL NOT
>> WORK AT ALL with Qt 4.5!!! (This is always the case, Qt is backwards- but
>> not forwards- compatible.)
> FYI, while the above is still sane advice (it's always a good idea to verify
> that you aren't building against a newer Qt from a buildroot override!), Qt
> 4.6.2 is now queued for the stable updates (it was decided in today's KDE
> SIG meeting to push the big Qt 4.6.2 / KDE 4.4.0 / SIP 4.10 update set out),
> so this particular version bump should no longer be a source of trouble.
I guess I am wondering why such a change is being made in a "stable"
branch in the first place. Why isn't this sort of thing strictly
regards, tom lane
More information about the devel