Package maintainers -- want test results by mail?

Ville Skyttä ville.skytta at
Wed Jun 2 20:15:42 UTC 2010

On Wednesday 02 June 2010, James Antill wrote:

>  The self obsolete ones are wrong, being able to do:
> Name: foo
> Provide: bar = 2
> Obsolete: bar <= 2
> completely legal and needed for rename/merging

Yes (assuming you mean "Obsoletes: bar < 2", not "<= 2").

> which is why yum has them.

yum does not have them like that.  The Provides in it are unversioned.

Obsoletes: yum-skip-broken <= 1.1.18
Obsoletes: yum-basearchonly <= 1.1.9
Obsoletes: yum-allow-downgrade < 1.1.20-0
Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
Obsoletes: yum-plugin-protect-packages < 1.1.27-0
Provides: yum-skip-broken
Provides: yum-basearchonly
Provides: yum-allow-downgrade
Provides: yum-plugin-allow-downgrade
Provides: yum-protect-packages
Provides: yum-plugin-protect-packages

Fix: sed -i -e 's/\(Provides.*\)/\1 = %{version}-%{release}/' yum.spec

Self-obsoletion used to cause problems in various tools in the past.  I don't 
know if all of them contain workarounds nowadays, but on the other hand I 
don't think I've ever seen an actual valid use case for self-obsoletion.

More information about the devel mailing list