Fedora rawhide FTBFS status 2010-06-01 x86_64

Mamoru Tasaka mtasaka at ioa.s.u-tokyo.ac.jp
Fri Jun 4 07:30:50 UTC 2010

Hedayat Vatankhah wrote, at 06/04/2010 03:07 PM +9:00:
> Hi,
> My packages (rcsslogplayer and rcssmonitor) are being failed because of the lack of Qt dependencies (QtNetwork requires ssl and crypto libraries from openssl-devel package, and gobject-2.0 from glib2-devel). As these packages are required by Qt, I think they should be added to qt-devel dependencies. Should I fill a bug against Qt?
> Thanks,
> Hedayat

For now I just checked rcssmonitor and the cause for build failure is that
- While rcssmonitor explicitly uses Libs.private (from m4/qt.m4 in your source
   tarball) like
$ pkg-config --static --libs-only-l QtNetwork
-lQtNetwork -lssl -lcrypto -lQtCore -lpthread -lz -lm -ldl -lgthread-2.0 -lrt -lglib-2.0
qt(4)-devel does pull openssl-devel or so in.

However this is Libs.private dependency and man pkg-config says:
    This line should list any private libraries in use.  Private libraries are libraries which are not exposed through
    your library, but are needed in the case of static linking. This differs from Requires.private in that  it  refer‐
    ences libraries that do not have package files installed.
So as we don't do static linking, this should not be needed.

I tried to add
sed -i.nostatic \
     -e 's|--static||g' m4/qt.m4
and this seems to make build succeed (I just also tried the same fix for
rcsslogplayer and it succeeds)



More information about the devel mailing list