initscripts-9.12-1.fc13 update not installable

Michel Alexandre Salim michael.silvanus at
Mon Jun 7 22:42:35 UTC 2010

On Tue, Jun 8, 2010 at 12:31 AM, Michel Alexandre Salim
<michael.silvanus at> wrote:
> Here are the x86_64 package versions:
> $ rpm -q NetworkManager initscripts
> NetworkManager-0.8.0-0.4.git20100211.fc13.x86_64
> initscripts-9.11-1.fc13.x86_64
> and on the netbook:
> $ rpm -q NetworkManager initscripts
> NetworkManager-0.8.1-0.1.git20100510.fc13.i686
> initscripts-9.12-1.fc13.i686
> I tried updating with the updates repo disabled, but for some reason
> NM-0.8.1 is not picked up despite it being in the mirrors:
> $ sudo yum --disablerepo=updates update initscripts NetworkManager
> ...
> Setting up Update Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package initscripts.x86_64 0:9.12-1.fc13 set to be updated
> --> Processing Conflict: initscripts-9.12-1.fc13.x86_64 conflicts
> NetworkManager < 1:0.8.0-12.git20100504
> --> Finished Dependency Resolution
> Error: initscripts conflicts with NetworkManager
>  You could try using --skip-broken to work around the problem
> Any idea what could be causing this? If I try updating just
> NetworkManager, I get "No Packages marked for Update"
So I downloaded the F-13 0.8.1-0.1.git20100510 packages, and tried a
'yum localupdate' -- and surprisingly get a "Nothing to do" response
from yum. Both the 0.8.0-0.4 from the prerelease and the final
0.8.1-0.1 have epoch set to 1, but for some reason yum thinks 0.8.0 >

Getting more puzzling than ever. rpm -Uvh --test agrees with yum in
this case, that there is nothing to upgrade.

yum downgrade NetworkManager-0.8.1-0.1.git20100510.fc13 claims the
package does not exist, and rpm -Uvh --oldpackage does not do anything
either. *Very* odd.


More information about the devel mailing list