still a 2TB limit in F14 Anaconda, for LVM PV size

Zoltan Boszormenyi zboszor at
Fri Nov 12 07:50:19 UTC 2010


2010-11-11 20:54 keltezéssel, Eric Smith írta:
> I just tried to install F14 on a new server with a 7.6 TB RAID (five 
> Hitachi 2 TB drives on a 3ware 9750).  I was pleased to see that the 
> disk partitioning interface in Anaconda recognized the array and didn't 
> have a problem with the size, reporting it as 7629352 MB.  Unfortunately 
> it won't let me create an LVM PV larger than 2 TB (2095151 MB).  And if 
> I try to create two PVs, it limits them to 1 TB each.
> Is there any good reason to have this limit, or should I report it as a 
> bug against Anaconda (or some other component)?
> Thanks,
> Eric

I run into the same problem with installing F14 but fortunately
it's easily solvable. I have split my 3.6TB RAID10 array into
a 150GB boot volume plus the "rest". I wanted to put /home
to the 3.45TB volume but anaconda wanted to create an
MSDOS partition by default. The 150GB volume is bootable
from the BIOS, no problem, /boot, / and swap was put there.
I had to press Ctrl-Alt-F2 and used "parted" on the console
to create the GPT disklabel on the large volume and created
one partition covering it all. Then used anaconda to accept
the already existing partitions and used the large partition
for /home. Ext4 had no problems formatting it.

Best regards,
Zoltán Böszörményi

More information about the devel mailing list