/lib64/libm.so.6: could not read symbols: Invalid operation

Mamoru Tasaka mtasaka at ioa.s.u-tokyo.ac.jp
Sun Nov 21 07:28:57 UTC 2010


Eric "Sparks" Christensen wrote, at 11/21/2010 01:47 PM +9:00:
> I'm working on updating the GPredict package for F13, F14, F15, and EL6.
>   The package builds fine on F14 and F15 but on F13 it fails with the
> error '/lib64/libm.so.6: could not read symbols: Invalid operation'.
> You can see the logs and such in koji[0].
>
> Anyone have any ideas?  I thought this was dealing with the DSO problem
> but I thought I had ruled that out.
>
> [0] http://koji.fedoraproject.org/koji/taskinfo?taskID=2613802
>
>
> Thanks,
> Eric

Try to add "-lm". F-15 build contains -lm so it came from somewhere
else by chance, however F-13 build does not.

Regards,
Mamoru


More information about the devel mailing list