F13 update issue..

Marcela Mašláňová mmaslano at redhat.com
Thu Nov 25 16:31:18 UTC 2010


On 11/25/2010 02:15 PM, Michael Schwendt wrote:
> On Thu, 25 Nov 2010 06:12:17 -0600, Rex wrote:
>
>>> On Wed, 24 Nov 2010 13:25:15 -0700, Nathanael wrote:
>>>
>>>> Hello,
>>>>
>>>>    My aunt has F13 installed.. I got the following from her. Is this a
>>>> known bug ?? I can't make heads or tails of the error message or what to
>>>> tell her to do to resolve it.
>>>>
>>>> ERROR with rpm_check_debug vs depsolve:
>>>> perl-libs = 4:5.10.1-112.fc13 is needed by perl-4:5.10.1-112.fc13.i686
>>>> perl-libs = 4:5.10.1-112.fc13 is needed by perl-4:5.10.1-112.fc13.i686
>>>> Please report this error at http://yum.baseurl.org/report
>>>>
>>>> Something worth reporting to bugzilla?
>>> This is multiarch breakage, which has been found and reported
>>> long ago, but won't be fixed. 
>> Nathanael, yes bugzilla, its fixable with a simple Obsoletes (which I'll 
>> commit to help with).
> self-Obsoletes are a way to fix it, sure. It's one thing I tell packagers
> when they mail me in reply to broken deps reports. But when above I wrote
> it "won't be fixed" that refers to the result of the communication with
> Marcela Mašláňová about this.
Yes, we (Perl maintainers) already discussed this issue with you. But from
our point view it was problem of wrong script, which create perl-libs
for both
architectures (i686 and x86_64).
The easiest solution is to remove perl-libs-5.10.1-112.fc13.i686 from
system,
but I will test if "obsolete" would work.
Imho yum could do solve it, so I'll create a RFE request for this issue.

Regards,
Marcela

-- 
Marcela Mašláňová
BaseOS team Brno



More information about the devel mailing list