preventing md5 mismatch errors from compression changes

Andre Robatino robatino at
Sun Nov 28 08:25:49 UTC 2010

Toshio Kuratomi <a.badger <at>> writes:

> This could require different naames for the library too which will get a bit
> harder than just the binary name.

Sorry for the late reply. I just noticed the presence in Rawhide of the
xz-compat-libs package which provides the old compression with in
addition to xz-libs providing the new compression with (This was
also discussed in .) This
is great - however, applydeltarpm in Rawhide still fails with "md5 mismatch of
result" when the new RPM uses the old compression. Excuse my ignorance, but is
there some way to make it recognize the correct compression needed? I was hoping
to be able to generate functional deltaisos from F14 Final to various F15
milestones, but at this point it looks like it won't work (even when running
applydeltaiso on a system with the latest xz/deltarpm/deltaiso). If it could be
made to work, I could just document the procedure for temporarily updating the
necessary packages.

More information about the devel mailing list