F14 youtube support?

Petr Pisar ppisar at redhat.com
Thu Sep 2 10:34:10 UTC 2010

On 2010-09-01, Michał Piotrowski <mkkp4x4 at gmail.com> wrote:
> Is there any possibility to use Youtube in Fedora 14? First I tried to
> install Adobe Flash 10.1. I tried to copy flashlib to various dirs
> /usr/lib64/mozilla/plugins, /usr/lib/mozilla/plugins,
> ~/.mozilla/plugins, but about:plugins in Firefox doesn't show me any
> informationa about flash support.
Adobe Flash Player is not produced for x86_64 architecture by vendor.
(It used to be, however it containted serious security flaws). To use
it by 64b Firefox, you need to install a wrapper that converts 64b NPAPI
to 32b. However according my experience it causes crashes (tested on

So IMHO there is no way how to use Adobe Flash Player on x86_64.

> I installed gnash package and Firefox showed information about Adobe
> plugin - I tried to run some videos, but the only thing I saw was
> a fancy error message about gnash.

Which error message, which version?

I have no problem when Gnash 0.8.8 is compiled against ffmpeg (Gentoo again,

I tried this viedeo <http://www.youtube.com/watch?v=zoNvsiBTQDE> on
Fedora 13. It's compiled against Gstreamer, and it complainead about
missng AAC decoder. I installed gstreamer-plugins-bad
(http://www.gstreamer.net/data/doc/gstreamer/head/gst-plugins-bad-plugins/html/gst-plugins-bad-plugins-plugin-faad.html) and the sound in
Gnash started to work. Video worked already becuase of other gstreamer
plugin probably.

However these gstreamer plugins are not in offical Fedora repository
because of regional patents. They come from rpmfusion-free repositories.

-- Petr

More information about the devel mailing list