F14 youtube support?

Chris Jones chrisjones at comcen.com.au
Thu Sep 2 12:32:00 UTC 2010

On Thu, 2010-09-02 at 10:34 +0000, Petr Pisar wrote:
> On 2010-09-01, Michał Piotrowski <mkkp4x4 at gmail.com> wrote:
> >
> > Is there any possibility to use Youtube in Fedora 14? First I tried to
> > install Adobe Flash 10.1. I tried to copy flashlib to various dirs
> > /usr/lib64/mozilla/plugins, /usr/lib/mozilla/plugins,
> > ~/.mozilla/plugins, but about:plugins in Firefox doesn't show me any
> > informationa about flash support.
> Adobe Flash Player is not produced for x86_64 architecture by vendor.
> (It used to be, however it containted serious security flaws). To use
> it by 64b Firefox, you need to install a wrapper that converts 64b NPAPI
> to 32b. However according my experience it causes crashes (tested on
> Gentoo).
> So IMHO there is no way how to use Adobe Flash Player on x86_64.
> > I installed gnash package and Firefox showed information about Adobe
> > plugin - I tried to run some videos, but the only thing I saw was
> > a fancy error message about gnash.
> Which error message, which version?
> I have no problem when Gnash 0.8.8 is compiled against ffmpeg (Gentoo again,
> sorry).
> I tried this viedeo <http://www.youtube.com/watch?v=zoNvsiBTQDE> on
> Fedora 13. It's compiled against Gstreamer, and it complainead about
> missng AAC decoder. I installed gstreamer-plugins-bad
> (http://www.gstreamer.net/data/doc/gstreamer/head/gst-plugins-bad-plugins/html/gst-plugins-bad-plugins-plugin-faad.html) and the sound in
> Gnash started to work. Video worked already becuase of other gstreamer
> plugin probably.
> However these gstreamer plugins are not in offical Fedora repository
> because of regional patents. They come from rpmfusion-free repositories.
> -- Petr
> -- 
> devel mailing list
> devel at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/devel

Is this problem with flash not working on x86_64 architecture limited to
Fedora or what?
I use Ubuntu 10.04 64bit as my primary operating system and have 32bit
Flash installed with wrapper inside Firefox 4.0 beta 4 and have no
There I ask the question, what is wrong with doing the same thing in


Chris Jones <chrisjones at comcen.com.au>

More information about the devel mailing list