Recently FTBFS stfl, fails on ruby installation

Thomas Janssen thomasj at fedoraproject.org
Mon Sep 13 17:02:48 UTC 2010


On Tue, Sep 7, 2010 at 2:13 PM, Thomas Janssen
<thomasj at fedoraproject.org> wrote:
> Hi,
>
> i tested today why stfl FTBFS. I found out that it doesn't installs a
> file into /usr/lib.. but lib/..
> That happens just for the ruby part of stfl, the perl parts getting
> installed into /usr/lib.. just fine.
>
> http://koji.fedoraproject.org/koji/getfile?taskID=2450778&name=build.log
>
> I checked (thanks kalev) the %{!?ruby_sitearch: %global ruby_sitearch
> %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] ')} macro and
> added two lines:
> echo %ruby_sitearch
> echo `ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] '`
>
> the response is here:
> http://koji.fedoraproject.org/koji/getfile?taskID=2451304&name=build.log
>
> I have currently no further idea of what might be wrong. I need
> someone with more knowledge than i have about what's going on, or what
> could be the problem.
>
> The only different thing i saw, was the new ruby build in f14 and
> rawhide. Though i have no real clue if that *could* be the problem.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2464814

The above scratch build dist-f13 shows that it *was* working. Still i
haven't found what might cause this issue.

Good:
mkdir -p /builddir/build/BUILDROOT/stfl-0.21-10.fc13.x86_64/usr/lib64/ruby/site_ruby/1.8/x86_64-linux
Bad:
mkdir -p lib/ruby/site_ruby/1.8/i386-linux

But why o why

-- 
Best regards
Thomas


More information about the devel mailing list