To Require or not to Require?

Andreas Schwab schwab at
Thu Aug 11 14:13:48 UTC 2011

Michael Schwendt <mschwendt at> writes:

> No external package can build with new features of the new "foo-libs" package
> prior to making that package available in the buildroot.

How is the contents of the buildroot relevant to "yum install bar"?

> If "foo" is the base package of "foo-libs", and this -libs package has
> added symbols needed by programs in package "foo", an older release
> of "foo-libs" would not suffice. On the contrary, all programs
> linked with an older foo library will continue to work.

How is that different from the above?


Andreas Schwab, schwab at
GPG Key fingerprint = D4E8 DBE3 3813 BB5D FA84  5EC7 45C6 250E 6F00 984E
"And now for something completely different."

More information about the devel mailing list