SOLVED (open-vm-tools): Re: F15: need help packaging / VMware-Data-Recovery

Reindl Harald h.reindl at
Thu Dec 8 00:50:01 UTC 2011

open-vm-tools for recent Fedora 15 kernels and VMware-HA/dataRecovery
see below

Am 08.12.2011 01:19, schrieb Marcelo Vanzin:
> On 12/07/2011 04:14 PM, Reindl Harald wrote:
>> Patch #2 (open-vm-tools-vsync.patch): + /bin/cat
>> /home/builduser/rpmbuild/SOURCES/open-vm-tools-vsync.patch + /usr/bin/patch
>> -s -p1 --fuzz=0
> Perhaps you should use -p0 instead? I don't know, I don't have your rpmbuild
> setup here so I can't suggest many things. It's a one-line change, so worst
> case you can manually create the patch against your tree.

vnd-backup of the buildserver is currently at 45%

this is my src.rpm for fedora 15 >= 2.6.41
cross-post on fedora-devel/fedora-users/rpmfusion list

hopefully that it helps people standing in the rain since rpmfusion is missing updates

this package is intentent to be used on servers and builds no gui-tools/dependencies
and no shared-folders modules to get rid of some unwanted packages, it also removes
VMXNET2 since VMXNET3 is included in the upstream kernel

it does not use any kmod-tools, so you need one buildmachine with disabled HA to rebuild the
package after update/reboot this machine and distribute it with the matching kernel from your
own repo to the other machines where you should be aware to boot with the old kernel as long
HA is active with automatic restart of frozen guests!

> The kernel may also return EBUSY if the superblock is already frozen, which
> can happen if, for example, multiple mount points exist

makes sense and matches to my most-hated change nobody cares
wondering why it worked in my first test, but who cares now

i do not know much about diff/patch but some changes at the begin
made the difference, removing the first two lines und the subfolder
"a/" and "b/" in the first lines

that is why i prfer the "snapshot" open-vm-tools since fedora tends to
use recent software and the frozen versions are mostly problematic
to compile

> --- open-vm-tools/lib/syncDriver/syncDriverLinux.c
> +++ open-vm-tools/lib/syncDriver/syncDriverLinux.c
> @@ -191,9 +191,13 @@ LinuxDriver_Freeze(const char *paths,
>           * supported on the device, we get EOPNOTSUPP. Ignore the latter,
>           * since freezing does not make sense for all fs types, and some
>           * Linux fs drivers may not have been hooked up in the running kernel.
>+          *
>+          * The kernel may also return EBUSY if the superblock is already
>+          * frozen, which can happen if, for example, multiple mount points
>+          * exist.
>           */
>          close(fd);
>-         if (errno != EOPNOTSUPP) {
>+         if (errno != EOPNOTSUPP && errno != EBUSY) {
>             Debug(LGPFX "ioctl failed: %d (%s)\n", errno, strerror(errno));
>             err = first ? SD_UNAVAILABLE : SD_ERROR;
>             break;

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
Url : 

More information about the devel mailing list