syck-php and php 5.4

Remi Collet Fedora at FamilleCollet.com
Thu Dec 29 09:29:17 UTC 2011


Hi,

I'm working on PHP 5.4 as a fedora 17 feature
https://fedoraproject.org/wiki/Features/Php54

So, I'm testing extensions compatibility.

syck-php fails to build...

I have a trivial build patch and some minor improvements to the spec
(.so filters and %check)

https://github.com/remicollet/remirepo/commit/f2cec51b3fae9403bb4c849f1fcf9e0e46edbb00


The php extension in syck 0.61 seems really outdated. I think a better
solution will be to switch to php-pecl-syck 0.9.3 (more recent, even if
quite old : Nov 2008)

Pull request to fix php 5.4 build
https://github.com/indeyets/syck/pull/7


Comments ?



P.S. of course I could take of the php-pecl-syck review, or even propose
the package.


More information about the devel mailing list