rawhide woes

Jim Meyering jim at meyering.net
Thu Feb 3 21:21:56 UTC 2011

TL;DR if you have a working rawhide system, you may want to refrain
from updating it for a little while.

I have been maintaining a headless rawhide system for more than two years,
updating every 1-4 days.  There have been a few hassles, but nothing
terrible.  Today however, after an update and a yum-complete-transaction
(which killed all connections), it became unbootable.  It could be my
fault for not waiting long enough before power cycling it -- in case the
complete-transaction was still running.  I tried the preceding kernel
with the same result.

I haven't given up, but was motivated to get a working rawhide system:
I'm releasing coreutils-8.10 tomorrow and the only btrfs
that was new enough to pass a failing test was on rawhide, yet
there was one other test that failed even on rawhide, and Josef
Bacik had given me a hint on how to work around it (use filefrag's -s

Thinking it might be easier to install a new system, I first
tried the latest nightly, desktop-x86_64-20110130.16.iso,
but that has its own problem:

  "Install to harddrive" fails with "not a live image"

So I installed from an F14 image, updated, then tried to upgrade to
rawhide.  There were lots of package conflicts and my VM was oom-killed,
so I had to rebuild the rpm db (so again could be my fault),
but in the end, with the new kernel, the system fails to boot,
now with this:

[    0.021998] NMI watchdog disabled for cpu0: unable to create perf event: -2
[    0.035026] NMI watchdog disabled for cpu1: unable to create perf event: -2
[    0.047172] NMI watchdog disabled for cpu2: unable to create perf event: -2
[    0.059012] NMI watchdog disabled for cpu3: unable to create perf event: -2
[    0.737139] Kernel panic - not syncing: UFS: Unable to mount root fs on unXno
[    0.737820] Pid: 1, comm: swapper Not tainted 2.6.38-0.rc3.git0.1.fc15.x86_64
[    0.738435] CaII Trace:
[    0.738714]  [<ffffffff814673e7_] T panic+0x91/0x19c
[    0.739252]  [<ffffffff81b58211_] T mount_block_root+0x250/0x27b
[    0.739809]  [<ffffffff81b583c2_] T mount_root+0x53/0x57
[    0.740284]  [<ffffffff81b58533_] T prepare_namespace+0x16d/0x1a6
[    0.740808]  [<ffffffff81074387_] T put_cred_rcu+0x0/0x8f
[    0.741283]  [<ffffffff81b57efd_] T kernel_init+0x29d/0x2a2
[    0.741651]  [<ffffffff8100a9e4_] T kernel_thread_heIper+0x4/0x10
[    0.741883]  [<ffffffff81b57c60_] T kernel_init+0x0/0x2a2
[    0.742109]  [<ffffffff8100a9e0_] T kernel_thread_heIper+0x0/0x10

Next time I'll save a copy of the updated F14 system before
jumping into rawhide.

More information about the devel mailing list