state of systemd in Fedora and services pledge

Toshio Kuratomi a.badger at
Wed Feb 23 17:56:21 UTC 2011

On Wed, Feb 23, 2011 at 04:34:00PM +0000, "Jóhann B. Guðmundsson" wrote:
> On 02/23/2011 03:04 PM, Toshio Kuratomi wrote:
> > Are you proposing that system V init scripts be banned for F15 and that we
> > do not allow upgrades from F14 to F15, only new installs?
> The backwards compatibility code would never have been added if that had 
> ever been the intention now would it :)
> > If you aren't proposing that, then testing that we can successfully upgrade
> > from a systemVinit script using package to a systemd unit file using package
> > is a test that needs to pass.
> First could you be a bit more specific what exactly is the problem so we 
> can test for that when we host systemd test day if I'm getting you right 
> what you are describing might fall under release blocker...
> As I get it we have a package with $oldversion with the traditional init 
> script now there is an update/upgrade that contains a $new-version with 
> systemd native service files and that update/upgrade is failing somehow?
> As Lennart mentioned have you tried chkconfig 1.3.50-1 [1] it contains 
> few patches from him amongst [2]...
> systemd "compatibility" was only added to chkconfig couple of days ago 
> up to that point systemd and chkconfig did not compute each other :)
> 1.
> 2. 
Looking at that patch it looks like all it does is have chkconfig forward
a request on to systemd if the package included systemd unit files.  If it
does more than that please let me know as that would mean that we'd need to
test upgrading from F14 to F15 separately from upgrading a sysv initscript
using package to a systemd unit file package on F15.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
Url : 

More information about the devel mailing list