RPM version goes backward in Rawhide

Tomas Mraz tmraz at redhat.com
Tue Jul 26 20:12:45 UTC 2011

On Tue, 2011-07-26 at 13:59 -0600, Jerry James wrote: 
> I just did a "package-cleanup --orphans" on my Rawhide machine to see
> which of the just-blocked packages are installed there.  To my
> surprise, I got this:
> # package-cleanup --orphans
> Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
> [snip stuff that I need to take care of]
> rpm-4.9.1-2.fc16.x86_64
> rpm-build-4.9.1-2.fc16.x86_64
> rpm-build-libs-4.9.1-2.fc16.x86_64
> rpm-devel-4.9.1-2.fc16.x86_64
> rpm-libs-4.9.1-2.fc16.x86_64
> rpm-python-4.9.1-2.fc16.x86_64
> # repoquery rpm
> rpm-0:4.9.0-10.fc16.x86_64
> Was this intentional?

Yes, rpm-4.9.1 has seriously broken rpmbuild process.
Tomas Mraz
No matter how far down the wrong road you've gone, turn back.
                                              Turkish proverb

More information about the devel mailing list