patch only if dependent version < x? (rpm spec)

Sam Varshavchik mrsam at courier-mta.com
Thu Jun 2 15:37:10 UTC 2011


Neal Becker writes:

> How can I apply a patch only if the version of a dependency is < x?

You mean you want to specify the dependency's version in a macro, that you  
put into Requires:? If so, just use the macro in your build script, it'll be  
expanded, and you can test its value. Bare-bones shell isn't usually  
convenient for understanding most kinds of version number formats. You may  
need to do something fancy.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
Url : http://lists.fedoraproject.org/pipermail/devel/attachments/20110602/45d55d9a/attachment.bin 


More information about the devel mailing list