system can't finish boot with systemd-28-4.fc16 and kernel-3.0-0.rc2.git0.2.fc16

Jerry James loganjerry at
Tue Jun 14 21:31:39 UTC 2011

On Tue, Jun 14, 2011 at 3:08 PM, Daniel J Walsh <dwalsh at> wrote:
> Hash: SHA1
> On 06/14/2011 04:42 PM, Jerry James wrote:


>> Like Lucas, I can boot with selinux=0.  I did so, and upgraded to
>> today's Rawhide packages.  Since reinstalling selinux-policy and
>> selinux-policy-targeted has been mentioned, I tried that.  Yum
>> reported no errors.  On reboot, I got all the way to gdm, but ran into
>>  After making
>> the symbolic link by hand and touching /.autorelabel, I rebooted.  I
>> got a hang in the same place.  So I rebooted with enforcing=0.  I got
>> a hang in the same place.                                 ^
>                                                            |
> Could you boot in permissive mode and after you boot run   |
You mean with enforcing=0?  It hangs -------------------------

Actually, I just got lucky.  I've tried rebooting a few more times,
since past experience has shown that once in awhile the boot is
successful.  Since I touched /.autorelabel, I just got a full relabel.
 Lots and lots of file relabels.  And on reboot, it has now hung in
the same place once again.

(* several reboots later *)

Okay, I got a successful rescue shell with "enforcing=0 single".  And
"restorecon -R -v /var" shows no output.  I'll stay in the rescue
shell for awhile in case anyone has any other ideas.
Jerry James

More information about the devel mailing list