F17 heads up: X server git snapshots

Adam Williamson awilliam at redhat.com
Mon Nov 14 20:56:04 UTC 2011


On Mon, 2011-11-14 at 09:42 -0500, Adam Jackson wrote:
> On Mon, 2011-11-14 at 06:48 -0500, Mystilleef wrote:
> > Hello,
> > 
> > Wow, I read this a little too late. I did an update, using
> > --skip-broken, today and now Xorg is broken. I use the open source ati
> > drivers. The Xorg log indicates a version mismatch between Xorg and
> > the drivers. Is there a way to reverse or fix this?
> 
> Get the list of X packages you have installed, download the F16 builds
> of same from koji, and downgrade to them.  Something like this perhaps:
> 
> $ rpm -qa --qf="%{name}\n" xorg-x11-\* | xargs -n 1 koji download-build
> --latestfrom=f16-updates --arch=$(arch)
> $ sudo rpm -Uvh --oldpackage xorg-x11-*$(arch).rpm
> 
> Probably there's a way to achieve the same thing that won't end with yum
> complaining about the rpmdb being modified behind its back, but meh.

Set up the F16 repos and do 'yum downgrade'.
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net



More information about the devel mailing list