Fwd: TFTP stopped working on F14

"Jóhann B. Guðmundsson" johannbg at gmail.com
Fri Oct 7 16:15:31 UTC 2011

On 10/07/2011 03:38 PM, Aaron Gray wrote:
> Hi,
> I think this is a development problem. I have tried everything obvious 
> to get TFTP to work on F14 but to no avail. Could some one in the know 
> look in to this please.
> I have tftp -server working on F14 and have done PXE Instillations 
> using it. Since then I have done a yum update and ever since then have 
> not been able to get it to work.

Well you can run yum downgrade on the updates that you performed to nail 
down the one that potentially broke it.

> Below in the two posts are what I have tried, as far as I can see it 
> is exhaustive.
> Many thanks in advance,

Well posts or not here is a quick debugging guide for tftp which should 
tell you what's going on and note that using ip-aliase are broken in 
tftp as it seem to be in (x)inetd based services in general...


#tcpdump port 69 -v

#touch /var/lib/tftpboot/my-test-file.txt
#chmod 777 /var/lib/tftpboot/my-test-file.txt

#tftp $IP
tftp> status
tftp> trace
tftp> verbose
tftp> put my-test-file.txt ( or get my-test-file.txt )
tftp> quit

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/devel/attachments/20111007/c680648c/attachment.html 

More information about the devel mailing list