yum update -- F16-latest => rawhide

Michael Schwendt mschwendt at gmail.com
Tue Oct 11 11:59:39 UTC 2011

On Tue, 11 Oct 2011 17:19:22 +0530, KC (Kashyap) wrote:

> Heya,
> I'm trying to get rawhide running by yum updating a  minimal footprint F16 virtual
> machine. Only @core package, so no gnome-* nothing else.

And no /bin/sh either? It is provided by "bash".

> ERROR with transaction check vs depsolve:
> /bin/sh is needed by groff-base-1.21-5.fc17.x86_64

> Then re-tried :
> [root at dhcp201-139 ~]# yum --disablerepo=* --enablerepo=rawhide update
> Still no dice. As it still throws --  'ERROR with transaction check vs depsolve:'
> Any hints here?

(Sounds more like a subject for "test" list.)

Since this unresolved dependency is not listed in the daily rawhide report:

Can you dig further and find out why you don't have anything that provides
/bin/sh? How to do that? Prior to the upgrade attempt, query your local RPM
database *and* also use repoquery. Then ask repoquery with the rawhide repo
enabled. What do you get? Where did "bash" go?

More information about the devel mailing list