Firefox on Fedora: No longer funny

Bill Nottingham notting at
Tue Oct 11 14:36:01 UTC 2011

Thomas Spura (tomspur at said: 
> > If the required updates are due to version checks in the extensions,
> > it might be possible to have RPM have a dependency generator that
> > checks these and outputs the appropriate Requires/Conflicts lines,
> > such that this could be easily caught by AutoQA.
> Generally speaking, could be possible (didn't look at other extensions).
> I'll try to script somthing for the requires generation
> like /usr/lib/rpm/ But it won't be possible to easily
> generalize requires, it would be better to have Conflicts:
>    <!-- Firefox -->
>    <em:targetApplication>
>      <Description>
>      <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
>      <em:minVersion>3.0</em:minVersion>
>      <em:maxVersion>10.0a1</em:maxVersion>
>      </Description>
>    </em:targetApplication>
> There isn't only firefox in that file, there are many browsers that
> aren't available in fedora, so R: Flock >= 0.4 and R: Flock <= 2.0.*
> would be never fulfilled --> Choosing to conflict with all other
> versions.
> Would that be ok/sane?

You'd want:

Requires: firefox >= 3.0
Conflicts: firefox > 10.0a1

(You could do the first one as a conflicts, too, but since the package
is already going to have a Requires: on firefox, might as well just version


More information about the devel mailing list