TFTP not working on F15 as well as updated F14

Aaron Gray aaronngray.lists at
Wed Oct 12 14:04:18 UTC 2011

On 12 October 2011 14:57, Aaron Gray <aaronngray.lists at> wrote:

> On 11 October 2011 18:49, Tom Callaway <tcallawa at> wrote:
>> On 10/11/2011 01:46 PM, Aaron Gray wrote:
>> > I have two F15 machines one a desktop which is running the new Gnome 3
>> > desktop and a laptop not running the new desktop.
>> >
>> > TFTP is not working on the desktop machine on F15 as it was not working
>> > on the updated F14. It worked on F14 before the update. I installed two
>> > servers using PXE using it.
>> I assume you mean "TFTP server", here. Can you attach copies of the
>> relevant config files and any errors that show up in the logs (server or
>> client side)?
> Configuration files attached, if you need any others just ask.
> AFAICT (by using my F15 laptop on which TFTP is working fine) both client
> and server are failing and causing time outs on my desktop F15 machine
> running new Gnome 3 desktop.
> No packets are transferred so it is not like bug 739534<>
> [root at XXXX ang]# netstat -a -n -p --ip|grep xinetd
> udp        0      0        *
> 1118/xinetd
> I have tried disabling both iptables and sellinux.
> [root at XXXX ang]# tail /var/log/messages
> Oct 12 14:17:29 gold xinetd[1118]: Exiting...
> Oct 12 14:18:19 gold xinetd[2886]: xinetd Version 2.3.14 started with
> libwrap loadavg labeled-networking options compiled in.
> Oct 12 14:18:19 gold xinetd[2886]: Started working: 2 available services
> rsync (the other service) appears to be working correctly.
> Anything else you need just shout.
> Many thanks for looking into this,
Additional iptables config files that did not get sent by gmail inline.

[root at XXXX etc]# cat iptables
# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
-A INPUT -m state --state NEW -m udp -p udp --dport 69 -j ACCEPT

[root at XXXX etc]# cat iptables-config
# Load additional iptables modules (nat helpers)
#   Default: -none-
# Space separated list of nat helpers (e.g. 'ip_nat_ftp ip_nat_irc'), which
# are loaded after the firewall rules are applied. Options for the helpers
# stored in /etc/modprobe.conf.

# Unload modules on restart and stop
#   Value: yes|no,  default: yes
# This option has to be 'yes' to get to a sane state for a firewall
# restart or stop. Only set to 'no' if there are problems unloading
# modules.

# Save current firewall rules on stop.
#   Value: yes|no,  default: no
# Saves all firewall rules to /etc/sysconfig/iptables if firewall gets
# (e.g. on system shutdown).

# Save current firewall rules on restart.
#   Value: yes|no,  default: no
# Saves all firewall rules to /etc/sysconfig/iptables if firewall gets
# restarted.

# Save (and restore) rule and chain counter.
#   Value: yes|no,  default: no
# Save counters for rules and chains to /etc/sysconfig/iptables if
# 'service iptables save' is called or on stop or restart if SAVE_ON_STOP or
# SAVE_ON_RESTART is enabled.

# Numeric status output
#   Value: yes|no,  default: yes
# Print IP addresses and port numbers in numeric format in the status

# Verbose status output
#   Value: yes|no,  default: yes
# Print info about the number of packets and bytes plus the "input-" and
# "outputdevice" in the status output.

# Status output with numbered lines
#   Value: yes|no,  default: yes
# Print a counter/number for every rule in the status output.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the devel mailing list