[HEADS UP] rename cryptsetup-luks to cryptsetup and libcrypsetup version bump

Richard W.M. Jones rjones at redhat.com
Fri Oct 14 11:56:40 UTC 2011


On Fri, Oct 14, 2011 at 12:40:33PM +0200, Milan Broz wrote:
> cryptsetup-luks name was old relict, so I decided to rename
> it back to cryptsetup (as in upstream and all other distros).
> 
> With this change comes also update to 1.4.0 version which
> removes old API (not used for years) and it requires libcryptsetup
> library version bump.
> 
> (Of course only in rawhide.)
> 
> These packages need to be rebuild (I'll try to ping maintainers):
> 
> systemd

This change seems to have broken the Rawhide buildroot:

DEBUG util.py:281:  Executing command: /usr/bin/yum --installroot /var/lib/mock/f17-build-1159809-181633/root/  groupinstall srpm-build
DEBUG util.py:247:  Ignored option -c (probably due to merging -yc != -y -c)
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Package cryptsetup-luks-libs is obsoleted by cryptsetup-libs, but obsoleting package does not provide for requirements
DEBUG util.py:247:  Error: Package: systemd-36-3.fc16.x86_64 (build)
DEBUG util.py:247:             Requires: libcryptsetup.so.1(CRYPTSETUP_1.0)(64bit)
DEBUG util.py:247:             Available: cryptsetup-luks-libs-1.3.1-2.fc16.x86_64 (build)
DEBUG util.py:247:                 libcryptsetup.so.1(CRYPTSETUP_1.0)(64bit)
DEBUG util.py:247:   You could try using --skip-broken to work around the problem
DEBUG util.py:247:   You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:247:  Error: Package: systemd-36-3.fc16.x86_64 (build)
DEBUG util.py:247:             Requires: libcryptsetup.so.1()(64bit)
DEBUG util.py:247:             Available: cryptsetup-luks-libs-1.3.1-2.fc16.x86_64 (build)
DEBUG util.py:247:                 libcryptsetup.so.1()(64bit)

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
libguestfs lets you edit virtual machines.  Supports shell scripting,
bindings from many languages.  http://libguestfs.org


More information about the devel mailing list