[HEADS UP] rename cryptsetup-luks to cryptsetup and libcrypsetup version bump

David Cantrell dcantrell at redhat.com
Fri Oct 14 12:19:48 UTC 2011


On 10/14/2011 06:40 AM, Milan Broz wrote:
> Hi,
>
> cryptsetup-luks name was old relict, so I decided to rename
> it back to cryptsetup (as in upstream and all other distros).
>
> With this change comes also update to 1.4.0 version which
> removes old API (not used for years) and it requires libcryptsetup
> library version bump.
>
> (Of course only in rawhide.)
>
> These packages need to be rebuild (I'll try to ping maintainers):
>
> systemd
> volume_key
> pam_mount
> python-cryptsetup
> python-volume_key
> libguestfs (this should require only binaries, not cryptsetup library, seems like a bug)

You forgot anaconda in this list.  It's easy to see what packages 
require another package with repoquery.

We'll include the Requires change in our next rawhide build.

-- 
David Cantrell <dcantrell at redhat.com>
Supervisor, Installer Engineering Team
Red Hat, Inc. | Westford, MA | EST5EDT


More information about the devel mailing list