Systemd conversion versus updates in back Fedora branches

Bill Nottingham notting at redhat.com
Mon Oct 24 16:01:27 UTC 2011


Tom Lane (tgl at redhat.com) said: 
> FWIW, I'm totally on board with the idea of not switching to systemd in
> F15 --- and even if I wanted to do that, it's pure luck that the problem
> doesn't apply to F14->F15 upgrades as well, where such an option is
> certainly not available.  The reason F14 escapes the problem is that
> we went to a new mysql major release series in F15, something that
> happens maybe once every three years or so.  (The last-minute upgrade to
> postgresql 9.1.x in F16 is likewise the only reason why I'm not bitching
> about this with respect to postgresql too.  And I suspect a whole lot of
> other packagers are up against similar issues, or will be if they take
> back-branch maintenance seriously.)
> 
> What I want is a packaging guideline that doesn't simply blow off
> the problem of upgrading packages in pre-systemd branches.  It's not
> an acceptable restriction, and I'm astonished that anybody ever thought
> it would be.

Make the upgrade trigger idempotent enough to not cause changes if
it triggers in a case where it didn't need to?

Bill


More information about the devel mailing list