php-pear package build problem

TASAKA Mamoru mtasaka at fedoraproject.org
Sun Sep 4 22:26:49 UTC 2011


Pavel Alexeev (aka Pahan-Hubbitus) wrote, at 09/05/2011 03:59 AM +9:00:
> Hello.
>
> I have couple of bugs with FBFS similar to [1]. At first glance it is trivial - php-config doesn't found [2].
>
> But what interesting, it still there as was in Fedora 15:
> [pasha at vbox temp]$ repoquery --whatprovides '*/php-config'
> php-devel-0:5.3.6-2.fc15.i686
> [pasha at vbox temp]$ repoquery --disablerepo='*' --enablerepo='rawhide' --whatprovides '*/php-config'
> php-devel-0:5.3.8-1.fc17.i686
>
> And php-devel BR is explicitly mentioned in spec as:
> BuildRequires: php-devel >= 5.1.0
>
> But what very interesting according to root.log [3] it wasn't pulled, and even no error produced?
>
> What happened??
>
> 1 - https://bugzilla.redhat.com/show_bug.cgi?id=715709
> 2 - http://koji.fedoraproject.org/koji/getfile?taskID=3323691&name=build.log
> 3 - http://koji.fedoraproject.org/koji/getfile?taskID=3323691&name=root.log

2. (build.log) says
error: /builddir/build/SPECS/php-pecl-runkit.spec:33: parseExpressionBoolean returns -1

This means that there is something wrong (syntax error or so) with your spec file.
To investigate further actually seeing the used spec file is needed.

Regards,
Mamoru





More information about the devel mailing list