Compiling 32bit on 64bit Fedora

Nathaniel McCallum nathaniel at
Wed Sep 7 16:23:11 UTC 2011

On Wed, Sep 7, 2011 at 12:15 PM, Ricky Zhou <ricky at> wrote:
> On 2011-09-07 12:04:06 PM, Nathaniel McCallum wrote:
>> That was what I thought... Sot it was the first thing I tried (note,
>> this is F16):
>> $ sudo yum install glibc-devel.i686
>> Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit,
>> remove-with-leaves, rpm-warm-cache, show-
>>               : leaves, versionlock
>> Loading mirror speeds from cached hostfile
>>  * fedora:
>>  * updates:
>>  * updates-testing:
>> Setting up Install Process
>> No package glibc-devel.i686 available.
>> Error: Nothing to do
> Strange - just tried a yum clean all followed by yum install
> glibc-devel.i686 libgcc.i686 on Kevin's F16 test machine - maybe
> whatever issue with glibc-devel in the repos has been fixed now?

I don't appear to have any i[356]86 packages in any of the repos on my
F16 box. Is there an rpm I'm missing?

More information about the devel mailing list