[Repost] What is "Error: Protected multilib versions"

drago01 drago01 at gmail.com
Thu Apr 5 12:42:25 UTC 2012

On Thu, Apr 5, 2012 at 2:41 PM, drago01 <drago01 at gmail.com> wrote:
> On Thu, Apr 5, 2012 at 2:23 PM, Richard W.M. Jones <rjones at redhat.com> wrote:
>> I still get this error several times a week, and I still have no idea
>> what it means or how I'm supposed to respond to it (other than
>> fiddling randomly with packages until it goes away).
>> The latest one:
>> # yum install /usr/sbin/libvirtd
>> [... yum spew deleted ...]
>> Error: Protected multilib versions: libvirt-client-0.9.10-2.fc17.i686 != libvirt-client-0.9.10-3.fc17.x86_64
>> $ rpm -qa | grep libvirt-client
>> libvirt-client-0.9.10-3.fc17.x86_64
>> What does the error mean?
> The 32bit and 64bit version of a lib must match.

Err clicked send too soon.

For some reason you seem to be installing -2.ii686 while you have
-3.x86_64 installed ... outdated mirror?

More information about the devel mailing list