Guaranteed way to break btrfs

valent.turkovic at valent.turkovic at
Thu Apr 19 14:23:44 UTC 2012

I found a perfect way how you can test small file issue in btrfs
because every time I tried it it breaks btrfs.

I tried on several partition with over 200+GB of free space, and after
starting openwrt compile process that creates few hundred thousand
small files I get "out of space" error.

On ext4 partition openwrt doesn't fail and it uses around 4GB of space.
All test were done on Fedora 16 with Linux 3.3.0 kernel.

And here are the instructions if you like to try out for yourself:

After finding out this issue I reformatted my /home and /storage
partitions to ext4.

I read on few mailing lists that this is an old and fixed btrfs issue,
but it looks that (at least in Fedora) it still affect some extreme
use cases, like building openwrt firmware.


follow me - &
linux, anime, spirituality, wireless, scuba, linuxmce smart home, zwave
ICQ: 2125241, Skype: valent.turkovic, MSN: valent.turkovic at

More information about the devel mailing list