rawhide report: 20121228 changes

Michael Scherer misc at zarb.org
Fri Dec 28 14:39:03 UTC 2012

Le vendredi 28 décembre 2012 à 13:02 +0000, Fedora Rawhide Report a
écrit :
> Compose started at Fri Dec 28 08:15:12 UTC 2012
> Broken deps for x86_64
> ----------------------------------------------------------
> [OpenImageIO]
> 	OpenImageIO-1.0.9-2.fc19.i686 requires libwebp.so.2
> 	OpenImageIO-1.0.9-2.fc19.x86_64 requires libwebp.so.2()(64bit)

a rebuild was enough to solve the deps issue, so maybe a PP could run
it ?

> [ember]
> 	ember-0.6.3-3.fc19.x86_64 requires libOgreMain.so.1.7.4()(64bit)

do not build, need a older version of Ogre

> [evolution-rss]
> 	1:evolution-rss-0.3.92-3.fc19.x86_64 requires libevolution-utils.so()(64bit)
> 	1:evolution-rss-0.3.92-3.fc19.x86_64 requires libemiscwidgets.so()(64bit)
> 	1:evolution-rss-0.3.92-3.fc19.x86_64 requires libemail-utils.so()(64bit)
> 	1:evolution-rss-0.3.92-3.fc19.x86_64 requires libedataserverui-3.0.so.5()(64bit)
> 	1:evolution-rss-0.3.92-3.fc19.x86_64 requires libcamel-1.2.so.42()(64bit)
checking for EVOLUTION_RSS_EPLUGIN... no
configure: error: Package requirements (  glib-2.0 >= 2.16.2    gtk+-3.0 >= 2.99.3    libsoup-2.4 >= 2.2    evolution-plugin-3.0 >= 2.91.6    evolution-shell-3.0 >= 2.91.6    libemail-utils libemail-engine libevolution-utils    libebook-1.2 ) were not met:
No package 'libemail-utils' found
No package 'libevolution-utils' found

As I think evolution changed upstream, this is surely something easy to fix.

> [freewrl]
> 	freewrl- requires libGLEW.so.1.7
> 	freewrl- requires libGLEW.so.1.7()(64bit)
> 	libEAI- requires libGLEW.so.1.7
> 	libEAI- requires libGLEW.so.1.7()(64bit)

Do not compile due to change in xulrunner :
/usr/include/xulrunner-17.0.1/jsapi.h:3649:1: note: expected 'struct
JSObject **' but argument is of type 'struct JSObject *'
world_script/JScript.c: In function 'JSCreateScriptContext':
world_script/JScript.c:407:3: warning: implicit declaration of function 'JS_NewCompartmentAndGlobalObject' [-Wimplicit-function-declaration]
world_script/JScript.c:407:14: warning: assignment makes pointer from integer without a cast [enabled by default]
world_script/JScript.c:410:3: error: too few arguments to function 'JS_NewGlobalObject'

> [gdal]
> 	gdal-1.9.1-14.fc19.x86_64 requires libwebp.so.2()(64bit)
> 	gdal-java-1.9.1-14.fc19.i686 requires libwebp.so.2
> 	gdal-java-1.9.1-14.fc19.x86_64 requires libwebp.so.2()(64bit)
> 	gdal-libs-1.9.1-14.fc19.i686 requires libwebp.so.2
> 	gdal-libs-1.9.1-14.fc19.x86_64 requires libwebp.so.2()(64bit)
> 	gdal-perl-1.9.1-14.fc19.x86_64 requires libwebp.so.2()(64bit)
> 	gdal-ruby-1.9.1-14.fc19.x86_64 requires libwebp.so.2()(64bit)
Rebuild seems to be enough

> [leptonica]
> 	leptonica-1.69-3.fc19.i686 requires libwebp.so.2
> 	leptonica-1.69-3.fc19.x86_64 requires libwebp.so.2()(64bit)

same as the others, a rebuild seems to be enough

> [meshmagick]
> 	meshmagick-0.6.0-13.svn2898.fc18.x86_64 requires libOgreMain.so.1.7.4()(64bit)
> 	meshmagick-libs-0.6.0-13.svn2898.fc18.i686 requires libOgreMain.so.1.7.4
> 	meshmagick-libs-0.6.0-13.svn2898.fc18.x86_64 requires libOgreMain.so.1.7.4()(64bit)
Fail to build due to some boost error :

/usr/bin/c++    -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic
-I/builddir/build/BUILD/meshmagick/include -I/usr/include/OGRE    -o
-c /builddir/build/BUILD/meshmagick/src/main.cpp
Linking CXX executable meshmagick
/usr/bin/cmake -E cmake_link_script CMakeFiles/meshmagick_bin.dir/link.txt --verbose=1
/usr/bin/c++   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic    -Wl,-z,relro  CMakeFiles/meshmagick_bin.dir/src/main.cpp.o  -o meshmagick -rdynamic libmeshmagick.so.0.6.0 -lOgreMain 
/usr/bin/ld: CMakeFiles/meshmagick_bin.dir/src/main.cpp.o: undefined reference to symbol '_ZN5boost6system15system_categoryEv'
/usr/bin/ld: note: '_ZN5boost6system15system_categoryEv' is defined in DSO /lib64/libboost_system-mt.so.1.50.0 so try adding it to the linker command line
/lib64/libboost_system-mt.so.1.50.0: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[2]: Leaving directory `/builddir/build/BUILD/meshmagick'

> [mygui]
> 	mygui-3.2.0-2.fc19.i686 requires libCommon.so
> 	mygui-3.2.0-2.fc19.x86_64 requires libCommon.so()(64bit)
> 	mygui-demos-3.2.0-2.fc19.x86_64 requires libCommon.so()(64bit)
> 	mygui-tools-3.2.0-2.fc19.x86_64 requires libCommon.so()(64bit)
Rebuild fine, but the Requires is still present.

> [root]
> 	root-graf3d-gl-5.34.02-1.fc19.x86_64 requires libGLEW.so.1.7()(64bit)
doesn't even let a srpm be created on F18, and fail on this line :

%if %{?fedora}%{!?fedora:0} >= 17 || %{?rhel}%{!?rhel:0} >= 7

( and as a side note, the spec could for sure benefit from some
cleaning, with conditional checking for fedora 11, or Group tag
everywhere )

> [rygel]
> 	rygel-0.17.0-1.fc19.i686 requires libgupnp-dlna-1.0.so.2
> 	rygel-0.17.0-1.fc19.x86_64 requires libgupnp-dlna-1.0.so.2()(64bit)
Missing deps :
configure: error: Package requirements (gupnp-1.0 >= $GUPNP_REQUIRED gee-0.8 >= $GEE_REQUIRED gupnp-av-1.0 >= 0.11.4 gstreamer-pbutils-1.0 >= 1.0 gupnp-dlna-1.1 >= 0.7.0) were not met:
No package 'gstreamer-pbutils-1.0' found
No package 'gupnp-dlna-1.1' found

> [spacechart]
> 	spacechart-0.9.5-8.fc18.x86_64 requires libaudiofile.so.0()(64bit)
rebuilding it make the requirement go away

So, if  proven packager could help to clean the list by rebuilding the
following, that would be nice :

- spacechart
- leptonica
- OpenImageIO
- gdal 

Michael Scherer

More information about the devel mailing list