nfs-utils requires modutils, but that is obsolete

Richard W.M. Jones rjones at
Wed Feb 8 11:56:56 UTC 2012

Currently in Rawhide it's impossible to update to the latest udev if
you have nfs-utils installed, because:

  Error: Package: 1:nfs-utils-1.2.5-11.fc17.x86_64 (@rawhide)
           Requires: modutils >= 2.4.26-9
           Removing: module-init-tools-3.16-5.fc17.x86_64 (@rawhide)
               modutils = 3.16
           Obsoleted By: kmod-5-4.fc17.x86_64 (rawhide)
               Not found

IIUC this suggests either that nfs-utils should be changed to depend
on kmod (but does this provide all of modutils?) or else kmod should
be changed to 'Provides' modutils.

The modutils explicit dependency was added ages ago:

  * Thu Mar 11 2004 Bill Nottingham <notting at>
  - rpc_pipefs mounting and aliases are now in modutils; require that 

whatever that means .. rpc_pipefs is in nfs-utils, so it could be the
dependency is now bogus.

Unfortunately removing nfs-utils isn't an option for me because that
would remove libvirt.


Richard Jones, Virtualization Group, Red Hat
virt-df lists disk usage of guests without needing to install any
software inside the virtual machine.  Supports Linux and Windows.

More information about the devel mailing list