UsrMove feature breaking "yum upgrade" upgrades from older releases to F17?

Ed Marshall esm at logic.net
Thu Jan 26 16:19:32 UTC 2012


On Thu, Jan 26, 2012 at 6:43 AM, Harald Hoyer <harald at redhat.com> wrote:
> Not really true. "yum upgrade" will be supported, but it needs a little help
> with a special initramfs and an additional kernel command line parameter, so
> that dracut can convert your filesystem. After this filesystem conversion, yum
> upgrade will work without problems.

This satisfies my needs; a reboot for conversion is not ideal, but not
the end of the world (and understandable, in this case).

There seems to be a great deal of resistance to the RPM changes that
are required, though, both for RHEL and Fedora (at least in their
respective BZ entries); will updated versions of rpm be generally
available in F16 and RHEL6 at the time of F17's release?

-- 
Ed Marshall <esm at logic.net>
Felix qui potuit rerum cognoscere causas.
http://esm.logic.net/


More information about the devel mailing list