another upgrade, another disaster

Martin Sourada martin.sourada at
Sat Jun 9 14:11:27 UTC 2012

I used preupgrade for the first time and had a similar experience, but
nothing one cannot fix...

1. Prepared the preupgrade process (f16->f17)
2. reboot and start upgrade
3. upgrade gets stuck on some package (IIRC it was something lisp
related). No CPU or HDD usage for about half an hour
4. got impatient, do a hard reboot start upgrade again
5. this time succeeds
6. no F17 kernel in grub, boot into F16 one
7. fix grub2 and discover zillions of duplicate packages (f16/f17)
8. try to remove, but discover texlive gets removed too
9. upgrade to texlive 2012 (there isn't f17 repo for 2011)
10. cleanup duplicate packages (package-cleanup --cleandupes)
11. do an update
12. everything works as expected (only grub does not show any theme,
why?), sans some gnome-dumb-down related things.

Right now I have only four grub2 and ibus related issues:
* How in the world do I tell grub2 to use the theme that's installed
  with it (it's beefy-miracle related)?
* How do I get ibus to use alt+shift resp. ctrl+alt+shift to switch
  between input methods? It worked in f16, now it complains
  alt+shift is not a valid key *confused*
* Where do I find and set Czech input method with qwerty layout instead
  of qwertz in ibus? It worked in f16, now the option seems gone :(
* How do I tell ibus to use input method per window, instead of
  desktop-wide? It worked in f16, now the setting seems gone :(

Just FYI, I'm using this on XFCE 4.10.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <>

More information about the devel mailing list